This project has moved and is read-only. For the latest updates, please go here.

I have this error log when attempting to scrape movies

Oct 27, 2016 at 5:00 PM
Please see this error log and help where you can?

27/10/2016 16:41:17

  • One or more errors were detected during scraping. See below for details. *
  • To disable seeing this, turn off General Preferences -'Show log on error'. *

Validating file Finding.Dory.2016.1080p.BluRay.H264.AAC-RARBG.mp4(1 of 1)


A total of 1 new movie found -> Starting Main Scraper Process...


Scraping Title: Finding Dory
Movie Body Scraped OK
HD Tags Added OK
Renamed Movie File to Finding Dory (2016).mp4
Renamed Subtitle File to Finding Dory (2016).sub and Finding Dory (2016).idx
Error - Running action [Rename] threw [Length cannot be less than zero.
Parameter name: length]

Finished
Oct 27, 2016 at 6:32 PM
Can you post the rename syntax you are using for the folders and for the filenames, ie: %T (%Y) etc.
Oct 27, 2016 at 8:34 PM
Okay, so for the Folders during autoscrape I use;

%N\%T (%Y)

And for the movie rename I use;

%T (%Y)

I have since performed a full scan of my movies and it has picked them all up okay, but this error occurs when I drag and drop the movie into the 'Movie List'. This is a method I have always used and never had this issue before. I am using a new version on a new computer so at first I though it could be a limitation on either of these, but I also tested on my old laptop with the old version of MC and the exact same thing happens.
Oct 28, 2016 at 1:29 AM
Tested and not getting this error.

Couple more things I need to know.
  1. Full filenames of the idx and sub files before renaming.
  2. Is the movie in a current Root Movie Folder within Media Companion
  3. Is the Movie already in its own folder?
And last, can you upload your config.xml file and paste a link for me to download.
Oct 28, 2016 at 7:00 AM
Even with the drag and drop method?
  1. Not an issue with the idx and sub files as even when attempting just the video file by itself this was happening.
  2. Yes, it's in my X:\Movies root folder.
  3. Movie is not in it's own folder
Can you talk me through uploading my .xml file?
Oct 28, 2016 at 7:37 AM
Tried drag and drop multiple times, all good.
  1. OK, glad to know its not an ancillary file.
  2. Same, from Root folder only, not in its own sub folder.
As for uploading the xml file, probably pastebin.com is the best option.
Open your config.xml and Select All, and then Copy.
Go to http://pastebin.com/ and paste into the panel.
Select the Syntax as XML (easiest to type XML)

Click 'Create new Paste' and you should get a URL, post this here.

Or, Duh! Open an issue here on Codeplex, and you can attach your config.xml to the issue.
Oct 28, 2016 at 7:59 AM
Here's the .xml link

http://pastebin.com/J37kqhy7
Oct 28, 2016 at 7:55 PM
Apart from one minor issue in your config.xml (which wasn't causing any problem), I still had success scraping Finding Dory by Drag and Drop.

Now, I did upload to my dropbox a test build, which has added logging of faults. Can you give this one a try, MC 3.664f x86.exe

I would suggest extracting this to its own folder, and setting up some dummy folders for testing.
Nov 1, 2016 at 7:01 PM
I don't know what is happening with your build, but it now starts moving all my movies from my NAS drive to the root of the C: drive, underneath the folder of the movie I am trying to drag and drop with.
Nov 2, 2016 at 10:25 PM
bjt2112 wrote:
I don't know what is happening with your build, but it now starts moving all my movies from my NAS drive to the root of the C: drive, underneath the folder of the movie I am trying to drag and drop with.
What the??

That shouldn't be happening, but, the latest test build does support long paths and I sure as hell hope that isn't causing this glitch.

Just to check

X:\ is a mapped network drive to your NAS?
X:\Movies is the only Movie root folder?
Is the new movie, in the C Drive? ie: C:\Finding.Dory.2016.1080p.BluRay.H264.AAC-RARBG\Finding.Dory.2016.1080p.BluRay.H264.AAC-RARBG.mp4

I need to get a clear picture where you are Dragging/Dropping from. In your post you mention movies being moved to the root of the C: drive, underneath the folder of the movie I am trying to drag and drop with. This makes it sound as if the new movie is not in a Root Movie folder that is stored in Media Companion.
Nov 10, 2016 at 8:28 PM
Okay, I'll try be as clear as possible with this one. So, X: is a mapped drive to my NAS, of which there are a few shared folders. The mapped drive is to the "videos" share on my NAS. Underneath the Videos share there are a few folders like Movies and TV. The movies from which I am dragging and dropping are in the root of the movies folder. Not in a separate folder within movies. On the official build of MC, it was throwing up the error. On your build of MC, it was starting to move all my movies from my NAS, to my C: drive, underneath the folder of the movie I had dragged and dropped. I only noticed this when my C drive was full, which I found extremely odd on a brand new computer.

For the time being, I run a full scan on that Movies folder within MC, and it picks up any new video in that folder, renames it correctly, and puts it in its own folder (Correctly named). This is a bit of a drag on such a large database and would be much easier if I could just drag the individual movie into MC.

Hope this makes sense...
Nov 16, 2016 at 8:44 PM
I have tried, tried again, and re-tried, and I can not get the issue to occur.

Drag and drop of Finding Dory mp4 works. Auto renaming/creating of the folder appears in the Root Movie folder. Renaming of the files works.
Only thing I noticed with your Folder structure string had leading and trailing "\", ie: _\%N\%Z (%Y) %V %O %M_

MC does this automatically as this is for the Folder, and we have a separate entry for the file naming.

I have done some tweaks to the renaming code, just to ensure the correct filenames are being used. Hopefully the next release will be functional again for you.
Jan 6 at 12:56 PM
I have downloaded the latest version and still having an issue with dragging and dropping. I copied the settings over but now, when it's attempting to scrape the metadata, it is actually moving the file to the root of my C: drive. This is the same problem I was having with a previous fix of yours, but different to what I experience on the previous version. Current version is 3.6.6.8
Jan 9 at 10:35 PM
I would start with a fresh clean copy of Media Companion, setting up your preferences instead of copying over your older config.

Do this in a new folder, as a test. I hope all goes well.
Feb 13 at 11:50 AM
Hi vbat99,

I have installed the latest version of MC, tried this again but it still doesn't work. What happens now is that the file that I drag into MC from file explorer is moved to the named folder within the root of C: rather than its own folder within X:\Movies
Feb 14 at 12:44 AM
OK, lets start from the beginning.
Upload your config.xml file to dropbox, googledrive etc and post a link in this thread.

At the same time, copy the path to your movies (that you drag and drop), and paste that path here as well.
Feb 14 at 10:45 AM
Hi,

Here is the link to my config.xml file,

https://drive.google.com/file/d/0Bw8CPyLk30dcdWUwR2xvdUM4NDg/view?usp=sharing

The path to my file location is X:\Movies

All my movies are located in separate folders beneath this. Upon further testing, it seems that if the movie is in a set, it starts moving all movies, but if it isn't it just moves the one movie into the root of the C drive.
Feb 15 at 6:54 AM
From your config.xml I see your on an older version of Media Companion, somewhere before MC 3.669b.

I would suggest you upgrade to the latest version, MC3.671b and re-test as plenty of code has changed.
I recommend a clean extract of MC ( to a new folder) and then copy over your Settings folder from your current version, to the new release.
Run Media Companion once, and then close it down. Then Re-run MC. This will allow new settings to be loaded with default values and saved to your config.

Do a clean extract also means you keep your current version handy, and only experiment with the new release. That is until your ready to use the latest release as your daily build.
Feb 15 at 8:00 AM
I did try that on the latest version with a singular test file and the same thing happened. I use this regularly as it contains my entire library. The results are the same no matter which version I use.
Feb 16 at 5:55 PM
After my last message, I thought I would try drag and drop anyway.

So with MC looking to X:\Movies.
I added two movies to the root of X:\Movies, 4th Man Out (2016), and Bridget Jones's Baby. (knowing the last movie is in a collection.
Dragged 4th Man Out and dropped on the list of Movies. MC scraped, renamed and created a folder for it.
Dragged Bridget Jones's Baby. MC scraped it, renamed and created a collection folder and a sub folder for Bridget Jones's Baby, and moved the movie into the folder.

So next I deleted all nfo's and extra files, and moved Bridget Jones's Baby folder out of its collection folder and left it beside 4th Man Out folder.
Dragged each movie individually into MC and dropped. No Problems.

Next left Bridget Jones's Baby folder in the collection folder and cleaned out all nfo's and extra files.
Dragged, dropped. No Problems.

Last attempt was clean out all files and drag drop the Folders. No Problems
Dragged both movie folders at once. No Problems.

This was using the config.xml file you uploaded, with me only removing the TV folders section.
I can not reproduce the issue.
Feb 17 at 6:47 AM
That is exactly how it has always worked for me, right up until around October last year when I posted this discussion. I will have one last attempt a bit later, and see if I can take screenshots to post along with any info that may seem pertinent.
Feb 17 at 9:26 AM
PS, What OS are you running?
Feb 17 at 4:45 PM
Windows 10