This project has moved. For the latest updates, please go here.
1

Closed

System.IndexOutOfRangeException

description

Happens when I try refresh from nfo in TV Shows.

System.IndexOutOfRangeException: Index was outside the bounds of the array.
at Media_Companion.Form1.tv_CacheRefresh(TvShow TvShowSelected)
at Media_Companion.Form1.RefreshThisShowToolStripMenuItem_Click(Object sender, EventArgs e)
Closed Aug 14 at 4:22 AM by vbat99
Fixed by end user.

comments

vbat99 wrote Aug 9 at 8:57 AM

Close Media Companion
rename your tvcache.xml file to tvcache.xml.old (in Settings folder)
Restart Media Companion and it should rebuild the TV Cache.

MAXsenna wrote Aug 12 at 2:32 PM

Thanks for the tip, but already tried it, and now this

System.IndexOutOfRangeException: Index was outside the bounds of the array.
at Media_Companion.Form1.tv_CacheRefresh(TvShow TvShowSelected)
at Media_Companion.Form1.util_ConfigLoad(Boolean prefs)
at Media_Companion.Form1.util_PrefsLoad()
at Media_Companion.Form1.Form1_Load(Object sender, EventArgs e)

I click continue, and then it hangs at "Status :- Building TV Database"m which never finishes...

It has made a new moviecache.xml, but not a tvcache.xml.

I am using the x64 version.

vbat99 wrote Aug 12 at 7:39 PM

I suggest starting with a clean Media Companion.
Close MC,
Rename the setting folder to Settings.old
Restart MC
Adjust your preferences.
Add your TV Folders.
Add your Movies.

Something is causing a hic-up, Not sure what exactly.

MAXsenna wrote Aug 12 at 9:45 PM

Yup! I fixed it myself this way.

Deleted settings folder, started MC and waited until it recreate settings folder. Restored config.xml and the postercache folder.

Then it retrived all movies and TV-shows. Found an .nfo file that somehow had become read only. Better Call Saul S03E08, had already deleted it once before. THEN could I search for new episodes and make them watched.
That was actually the start of these problems. Making shows watched.

Anyway, thanks for the help. All is ggod now!
Cheers,
Mats

vbat99 wrote Aug 14 at 4:21 AM

Sorry it had to be such a work-around to get MC humming again.
Not sure why a NFO would become read only, unless it didn't close the file correctly....

Glad you got it sorted in the end.