XBMC Link not updating with XBMCbuntu 12.2

Jul 26, 2013 at 2:56 AM
Parts of this might be the same problem as what Bloksel posted.

With XBMCbuntu 12.1 It appeard that I was able to connect and sync with XBMC. I didn't actually have a chance to verify that it was passing changes, but it did take a long time to do stuff. Since I loaded 12.2 I've been unable to get it to do anything.

It still flashes on the screen and says it's compressing, but nothing ever shows up. Also it's compressing goes really quick compared to how it was on 12.1

With 12.1 I was using the IP address in the Folder Mapping. For example "\192.168.1.40\Shows", because that's how I had it setup on 12.1. For some reason I couldn't get 12.1 to work with servernames. Now that it's on 12.2 it uses server names, for example "\MyServer\Shows".

I've tried these for the XBMC folder mapping:
\MyServer\Shows
smb://MyServer/Shows
smb:\MyServer\Shows
//MyServer/Shows

I also thought that it might be related to the known issue about movies having to be in sub-directories off the source, so I tried changing it so that the movies are in a sub-directory. It didn't make any difference. I did the "refresh" with the link enabled and that didn't do anything except let me watch the "jobs" number count down towards zero, even though it never actually makes it there.

It never reaches zero because the XBMC web service will stop responding to MC. This seems to happen at different points, but normally after about the 800 movie mark. XBMC will sometimes still be flashing the compressing message on and off the screen, but MC shows the link is down. If you go into the xbmclink config page and revalidate it will show red X's by the port, username, and password. I then reboot XBMC and the link works again. I tried doing the refresh several times and the furthest I got was about 1100 movies.

Those 'XBMC-Controller-full-log-file.txt' & 'XBMC-Controller-brief-log-file.txt' aren't being created on my system, so I can't look into them for any details.

One final comment, if you could find a way to keep the xbmclink popup on the screen that would be greatly appreciated. Right now it's a little annoying with the constantly popping up and dissappearing, over and over again. Another option might be to make it a status bar at the bottom of the screen.
Jul 26, 2013 at 3:51 AM
I had decided to remove all sources from XBMC and to add only one source back in. Then I was going to try to sync just one movie.

I removed the sources and then I cleaned the database. That's when things started to get weird. My XBMC still showed all the movies. So even though the "Movies" group was empty of sources the library still had the movies. So I deleted the "Movies" group, but I still had a "Movies" option on the main screen, and all the movies were there.

I then looked at the sources.xml file on XBMC and verified that it had no sources for videos.

It seem like MC was putting movies into the library that didn't actually belong to any group.

I then went and deleted MyVideos75.db and Textures13.db, and restarted XBMC. Once it came up I verified that there were no movies listed anymore, and the Movies option no longer showed on the main screen.

So with no movies on XBMC I went into MC and selected 3 movies and selected sync to XBMC. As expected, no movies were added to XBMC.

I then clicked on the refresh button in MC. It ran for a very long time, but did not actually add any movies to XBMC. Which is expected since XBMC still didn't have a Movies group or sources.

I then removed all sources from MC except for one, and on XBMC I created the Movies group and added the one source to it.

This actually caused MC to start throwing an error and I was unable to change the XBMC folder mappings in MC.
See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.InvalidOperationException: Collection was modified; enumeration operation may not execute.
   at System.ThrowHelper.ThrowInvalidOperationException(ExceptionResource resource)
   at System.Collections.Generic.List`1.Enumerator.MoveNextRare()
   at System.Collections.Generic.List`1.Enumerator.MoveNext()
   at Media_Companion.XBMC_MC_FolderMappings.RemoveInvalidFolders()
   at Media_Companion.XBMC_MC_FolderMappings.IniFolders()
   at Media_Companion.Preferences.LoadConfig()
   at Media_Companion.Form1.util_ConfigLoad(Boolean prefs)
   at Media_Companion.Form1.util_PrefsLoad()
   at Media_Companion.Form1.Form1_Load(Object sender, EventArgs e)
   at System.EventHandler.Invoke(Object sender, EventArgs e)
   at System.Windows.Forms.Form.OnLoad(EventArgs e)
   at System.Windows.Forms.Form.OnCreateControl()
   at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
   at System.Windows.Forms.Control.CreateControl()
   at System.Windows.Forms.Control.WmShowWindow(Message& m)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   at System.Windows.Forms.ContainerControl.WndProc(Message& m)
   at System.Windows.Forms.Form.WmShowWindow(Message& m)
   at System.Windows.Forms.Form.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.18051 built by: FX45RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
Media Companion
    Assembly Version: 3.5.7.3
    Win32 Version: 3.5.7.3
    CodeBase: file:///C:/temp/MediaCompanion/Media%20Companion.exe
----------------------------------------
Microsoft.VisualBasic
    Assembly Version: 10.0.0.0
    Win32 Version: 11.0.50709.17929 built by: FX45RTMREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.18033 built by: FX45RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.17929 built by: FX45RTMREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.18037 built by: FX45RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.18022 built by: FX45RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Runtime.Remoting
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.17929 built by: FX45RTMREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
NfoLibrary
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/temp/MediaCompanion/NfoLibrary.DLL
----------------------------------------
ProtoXML
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/temp/MediaCompanion/ProtoXML.DLL
----------------------------------------
TvdbScrapper
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/temp/MediaCompanion/TvdbScrapper.DLL
----------------------------------------
Common
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/temp/MediaCompanion/Common.DLL
----------------------------------------
System.Xml.Linq
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.17929 built by: FX45RTMREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml.Linq/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.Linq.dll
----------------------------------------
System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.18053 built by: FX45RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
wfcl_MC
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/temp/MediaCompanion/wfcl_MC.DLL
----------------------------------------
Utilites
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/temp/MediaCompanion/Utilites.DLL
----------------------------------------
Accessibility
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.17929 built by: FX45RTMREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Accessibility/v4.0_4.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------
Tasks
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/temp/MediaCompanion/Tasks.DLL
----------------------------------------
Sanford.StateMachineToolkit
    Assembly Version: 6.5.0.0
    Win32 Version: 6.5.0.0
    CodeBase: file:///C:/temp/MediaCompanion/Sanford.StateMachineToolkit.DLL
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.
So I went into the config.xml for MC and manually removed the folder mappings that didn't apply anymore. After that MC started without error. And immediately went through the refresh.

And still no movies, so I cleaned the database on XBMC one more time and rebooted it, and gave it one last try.
After all that I still have no movies on XBMC. So I can't explain how the other ones got inserted separate from a source.

As one last attempt I thought I might be reading the "Know Issue" about movies needing to be in sub-directories wrong. So I set MC and XBMC both up to where the movies were in a sub-directory. I had to manually change the config.xml file to get past the error again. Once that was done I redid the link and clicked on refresh again.

And again I ended up with no movies on XBMC.

At this point I'm out of ideas. I can't get it to update any of the databases on XBMC.
Coordinator
Jul 26, 2013 at 7:20 PM
Crash message has been fixed for the next release, but unable to assist in how to set up for XBMCbuntu.
Jul 26, 2013 at 7:53 PM
vbat99 wrote:
... but unable to assist in how to set up for XBMCbuntu.
I'm good on setting up XBMCbuntu, just need help on getting MC to actually talk to it. I think I'm done messing with it until the next release of MC. I'm hoping the issue is related to the problems Bloksel posted about.
Coordinator
Jul 26, 2013 at 8:32 PM
Trying to complete some layout fixes then will push a new release, Hopefully in next 24 hrs.
Jul 30, 2013 at 11:40 PM
Ok, so with MC v3.5.7.4 I've tried again, and still no luck.

I've done the Refresh with the link enabled, and that actually removed almost all the movies from my movie library on XBMC.

When I right click on a Movie and select "Sync to XBMC" I get those multiple XBMC Link popups. I do notice that the very first popup very quickly flashes a message that says "Failed to find movie id for ...."

Does that message mean that it's not finding the movie ID on MC or on XBMC?

As reported in my other issue the log files still aren't being generated by XBMCLink.

I've checked under 'Movies' and 'Files' in XBMC and neither location is being updated with the new fanart or poster I select in MC. MC will popup that XBMCLink window a bunch of times and I'll see the 'compressing' message flash on XBMC, but nothing actually happens.
Coordinator
Jul 31, 2013 at 6:55 PM
Phil's done a few more fixes, so will look at getting a release out soonish.
Aug 13, 2013 at 9:43 PM
Finally being able to see the logs did help me figure it out.

I know I tried this before, but setting the full smb://servername/foldershare path in the 'Movie Folder Mappings' is the last thing I did that finally got it to work. So it's possible that I also changed some other setting that helped fix it.

So for example on the MC side I have
\\DAGONET\DVDs\New
and on the XBMC side I have
smb://DAGONET/DVDs/New/
One thing I noticed is it seems like XBMC Link does double work. It seems to be deleting the movie and then adding it back in, instead of simply updating the movie information.

So I'll say it's working with XBMCUbuntu. I'll report any other issues I happen to run into.
Nov 4, 2013 at 4:17 PM
Edited Nov 4, 2013 at 6:59 PM
I run MC on a windows node, but XBMCbuntu on a separate machine. Storage is actually on other linux machine. MySql on a linux vm.
I finally upgraded to FRODO because I was so resistant to the JSON move and http api kill and I have some other apps/tools/scripts that leverage those.
So then I recalled MC also had this XBMC link that I could try now w/ FRODO.
I can get everything greened, except the Textures DB.
my config is:
\\nodename\system\userdata
\Database\Textures13.db
Thumbnails

Validate passes everything non TexturesDB related.
I just confirmed i could create a new file in \\nodename\system\userdata\database

Things to check:
- Warning: Some of your movies only have '.tbn' poster extensions, Frodo expects '-poster.jpg'. You can fix this by:
     - 1. Selecting 'Pre-Frodo poster only' from the 'General' Movie Filter
     - 2. Selecting all the movies in the list, then Rt-Click & select 'Convert to Frodo only'
Not sure I am understanding where this filter is at, but I am unable to attempt step 2.
Also my logs are empty.
Nov 4, 2013 at 9:28 PM
Transcender,

Take a look at this post:
https://mediacompanion.codeplex.com/workitem/994

I ran into both of those when I was trying to get mine setup. Basically you need to map a drive letter to fix the texture.db issue and use the General filter in the bottom left of the main movie screen to convert to filter the list to 'Pre-Frodo posters only' and then right click on them and convert to frodo only.

I think you can also use the batch rescraper to just rescrape the Frodo posters, but it's been awhile, so I don't remember.
Nov 4, 2013 at 9:44 PM
Edited Nov 5, 2013 at 4:14 PM
Strange figured if the userdata folder worked UNC; as well as the thumbnails; than the textures would?
Thanks for the specific help ImpDust;
My XBMC link is working now; very preliminarily it seems to work. A bit slow/clunky the gui goes a bit unresponsive but very interesting.

Update: the xbmc link is pretty dang awesome. Curious about the setup but we got to work i suppose.
really would love the tv counterpart. wtg guys.