Issue with Media Companion 3.597b (and other versions) on Windows 7 (x64)

May 29, 2014 at 10:15 PM
Hi, I am completely new to Media Companion (I have never used any software of this type before but have just installed XBMC on my Pi so thought I would go the whole hog and get up to this century :) ). I am running into an issue which Uncle Google is not helping me fix.

So it crashes on Startup and when looking at the event logs I am told the error is with KERNELBASE.dll.

This is what comes up in the crash log

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: media companion.exe
Problem Signature 02: 3.5.9.7
Problem Signature 03: 536c4fce
Problem Signature 04: System.Drawing
Problem Signature 05: 4.0.0.0
Problem Signature 06: 4ba1e086
Problem Signature 07: 67b
Problem Signature 08: 6c
Problem Signature 09: System.InvalidOperationException
OS Version: 6.1.7601.2.1.0.256.4
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

And this is what comes up in the event log:

Faulting application name: Media Companion.exe, version: 3.5.9.7, time stamp: 0x536c4fce
Faulting module name: KERNELBASE.dll, version: 6.1.7601.18409, time stamp: 0x53159a86
Exception code: 0xe0434352
Fault offset: 0x0000c42d
Faulting process id: 0x6f58
Faulting application start time: 0x01cf7b8b0c91a8e1
Faulting application path: C:\Users\Blade Hunter\Desktop\Media Companion 3.597b\Media Companion.exe
Faulting module path: C:\Windows\syswow64\KERNELBASE.dll
Report Id: 4ae1b1bf-e77e-11e3-868f-bc5ff4482791

I read a bunch of threads on crash on startup with a variety of solutions none of which helped. I removed my .net framework and reinstalled the one linked on the downloads page but that didn't help either.

I have already run the Run the System File Checker tool (SFC.exe) as suggested on the Microsoft site for this issue but there were no errors found.

Any ideas what I can do to resolve?

Thanks in advance for any help
Coordinator
May 29, 2014 at 11:17 PM
We have had this issue once before, but I do not recall how it was resolved.

Googling up on this I see a few suggestions.
I fixed this on my x64 win 7 machine setting service: "Performance Logs & Alerts" to automatic and starting.
and
solved it already, thanks. it is due to certain directory not given the appropriate rights.
also
I too had the problem,  upon checking the even viewer where it is clearly written that Configuration Manager exception in not Handled, this is many times the corrupted users configuration.

i log in  as another user, the application is working.
I'll look into this further, but it won't be for a day or so.
May 30, 2014 at 12:54 AM
Thanks for the quick reply, I tried the first one last night and it didn't resolve it. I will try the other ones when I get home from work today.

Many thanks
Coordinator
May 30, 2014 at 1:27 AM
Looking further into the error message, It seriously looks like MC can't create a log file in the MC folder.

Please check the folder is not in a restricted location, ie: Program Files? User Folder etc. Also, ensure the user running it has write permission on the folder.
Don't know if running as Administrator would make a difference?

I suggest extracting MC to the C Drive in it's own folder.
May 30, 2014 at 2:26 AM
I thought it may be something like permissions last night so I moved the folder to the root of C and tried, same issue i'm afraid :(.

What should the log file be called? Maybe if I create it myself it may be able to modify it??
Coordinator
May 30, 2014 at 2:50 AM
I believe it's one or both of these
XBMC-Controller-brief-log-file.txt
XBMC-Controller-full-log-file.txt

But if you moved the folder, it would still have the previous permissions.

Right-click the MC folder, and check the 'Security' tab. Make sure your user and Administrator have full control (Read/Write) permission on the folder, and sub folders.
Coordinator
May 30, 2014 at 3:53 AM
Here's a test build where I've added some exception handling. Hopefully this will give some better information so we can find out what is happening.
May 30, 2014 at 4:27 AM
Edited May 30, 2014 at 4:28 AM
OK, So I ran it and this is the result.

An error occurred creating the form. See Exception.InnerException for details. The error is: Font: 'Times New Roman' does not support style 'Regular'. Continue?

I Clicked Yes but it just disappeared from screen and out of running tasks in task manager.

Hope that helps.

Thanks for all this support too, really appreciate it.
Coordinator
May 30, 2014 at 4:36 AM
Seems you've got an issue with the New Times Roman font.

Try this
Start -> Run c:\windows\fonts\times.ttf
In the window that pops up, click the button Install

Try Media Companion again.
Marked as answer by vbat99 on 10/16/2015 at 12:26 PM
Coordinator
May 30, 2014 at 4:39 AM
Alternatively, you may need to uninstall the font and re-install.

Follow this guide, but copy the times.ttf or Times New Roman font. Font does not support style regular
Marked as answer by vbat99 on 10/16/2015 at 12:26 PM
May 30, 2014 at 4:41 AM
Had to do cour.ttf also but its bloody working now. Thank you so much for your help, I never would have been able to figure that out :).

Really appreciate your help :).

Thanks again

Dan
Coordinator
May 30, 2014 at 4:43 AM
Phew. Great news.

Something as simple as a corrupt font knocks a whole program out.

Well, that one to try and remember. And now that error handling is in place for future users.

Cheers and enjoy.

Rob